Home » Ubuntu系统入门教程 » Ubuntu系统入门教程-3D打印切片软件cura

Ubuntu系统入门教程-3D打印切片软件cura

说明

  • 本教程介绍如何在Ubuntu系统下安装和使用cura切片软件

  • 测试环境:Ubuntu 16.04 + cura 14.07

操作步骤

  • 下载cura安装包:下载链接

  • 下载完成后,解压

$ unzip cura_14.07-debian_amd64.zip 
Archive:  cura_14.07-debian_amd64.zip  
inflating: cura_14.07-debian_amd64.deb
  • 安装cura
$ sudo dpkg -i cura_14.07-debian_amd64.deb 
Selecting previously unselected package cura.
(Reading database ... 252764 files and directories currently installed.)
Preparing to unpack cura_14.07-debian_amd64.deb ...
Unpacking cura (14.01) ...
dpkg: dependency problems prevent configuration of cura:
 cura depends on python-wxgtk2.8; however:
  Package python-wxgtk2.8 is not installed.

dpkg: error processing package cura (--install):
 dependency problems - leaving unconfigured
Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20180209-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for desktop-file-utils (0.22-1ubuntu5.2) ...
Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
Processing triggers for mime-support (3.59ubuntu1) ...
Errors were encountered while processing:
 cura
ubuntu
  • 这里可能提示缺少python-wxgtk2.8,但是这个已经是旧版本,现在的源已经不含这个版本

  • 下面添加新的ppa源

$ sudo add-apt-repository ppa:codeblocks-devs/release
$ sudo apt-get update
  • 修复依赖
$ sudo apt-get install -f
[sudo] password for ubuntu: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  libllvm4.0 snapd-login-service
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  libgstreamer-plugins-base0.10-0 libgstreamer0.10-0 libwxbase2.8-0 libwxgtk-media2.8-0 libwxgtk2.8-0 python-wxgtk2.8
Suggested packages:
  libvisual-0.4-plugins gstreamer0.10-tools gstreamer0.10-plugins-base wx2.8-doc wx2.8-examples editra
The following NEW packages will be installed:
  libgstreamer-plugins-base0.10-0 libgstreamer0.10-0 libwxbase2.8-0 libwxgtk-media2.8-0 libwxgtk2.8-0 python-wxgtk2.8
0 upgraded, 6 newly installed, 0 to remove and 518 not upgraded.
1 not fully installed or removed.
Need to get 4,632 kB/8,551 kB of archives.
After this operation, 40.9 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://cn.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 libgstreamer-plugins-base0.10-0 amd64 0.10.36-2ubuntu0.2 [514 kB]                                      
Get:2 http://ppa.launchpad.net/codeblocks-devs/release/ubuntu xenial/main amd64 python-wxgtk2.8 amd64 2.8.12.1+dfsg2-ppa1~ubuntu16.04.1 [4,118 kB]                             
Fetched 2,120 kB in 21min 44s (1,625 B/s)                                                                                                                                      
Selecting previously unselected package libwxbase2.8-0:amd64.
(Reading database ... 253008 files and directories currently installed.)
Preparing to unpack .../libwxbase2.8-0_2.8.12.1+dfsg2-ppa1~ubuntu16.04.1_amd64.deb ...
Unpacking libwxbase2.8-0:amd64 (2.8.12.1+dfsg2-ppa1~ubuntu16.04.1) ...
Selecting previously unselected package libgstreamer0.10-0:amd64.
Preparing to unpack .../libgstreamer0.10-0_0.10.36-1.5ubuntu1_amd64.deb ...
Unpacking libgstreamer0.10-0:amd64 (0.10.36-1.5ubuntu1) ...
Selecting previously unselected package libgstreamer-plugins-base0.10-0:amd64.
Preparing to unpack .../libgstreamer-plugins-base0.10-0_0.10.36-2ubuntu0.2_amd64.deb ...
Unpacking libgstreamer-plugins-base0.10-0:amd64 (0.10.36-2ubuntu0.2) ...
Selecting previously unselected package libwxgtk2.8-0:amd64.
Preparing to unpack .../libwxgtk2.8-0_2.8.12.1+dfsg2-ppa1~ubuntu16.04.1_amd64.deb ...
Unpacking libwxgtk2.8-0:amd64 (2.8.12.1+dfsg2-ppa1~ubuntu16.04.1) ...
Selecting previously unselected package libwxgtk-media2.8-0:amd64.
Preparing to unpack .../libwxgtk-media2.8-0_2.8.12.1+dfsg2-ppa1~ubuntu16.04.1_amd64.deb ...
Unpacking libwxgtk-media2.8-0:amd64 (2.8.12.1+dfsg2-ppa1~ubuntu16.04.1) ...
Selecting previously unselected package python-wxgtk2.8.
Preparing to unpack .../python-wxgtk2.8_2.8.12.1+dfsg2-ppa1~ubuntu16.04.1_amd64.deb ...
Unpacking python-wxgtk2.8 (2.8.12.1+dfsg2-ppa1~ubuntu16.04.1) ...
Processing triggers for libc-bin (2.23-0ubuntu11) ...
Setting up libwxbase2.8-0:amd64 (2.8.12.1+dfsg2-ppa1~ubuntu16.04.1) ...
Setting up libgstreamer0.10-0:amd64 (0.10.36-1.5ubuntu1) ...
Setting up libgstreamer-plugins-base0.10-0:amd64 (0.10.36-2ubuntu0.2) ...
Setting up libwxgtk2.8-0:amd64 (2.8.12.1+dfsg2-ppa1~ubuntu16.04.1) ...
Setting up libwxgtk-media2.8-0:amd64 (2.8.12.1+dfsg2-ppa1~ubuntu16.04.1) ...
Setting up python-wxgtk2.8 (2.8.12.1+dfsg2-ppa1~ubuntu16.04.1) ...
Setting up cura (14.01) ...
Processing triggers for libc-bin (2.23-0ubuntu11) ...
  • 继续安装
$ sudo dpkg -i cura_14.07-debian_amd64.deb 
[sudo] password for ubuntu: 
(Reading database ... 253727 files and directories currently installed.)
Preparing to unpack cura_14.07-debian_amd64.deb ...
Unpacking cura (14.01) over (14.01) ...
Setting up cura (14.01) ...
Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20180209-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for desktop-file-utils (0.22-1ubuntu5.2) ...
Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
Processing triggers for mime-support (3.59ubuntu1) ...
  • 打开cura,设置好打印机类型及尺寸等
$ cura
load preferences from /home/ubuntu/.cura/14.07/preferences.ini

请输入图片描述

  • cura已成功安装

参考资料

纠错,疑问,交流: 请进入讨论区点击加入Q群

获取最新文章: 扫一扫右上角的二维码加入“创客智造”公众号


标签: ubuntu系统入门教程